Database Instability

Incident Report for NextQS

Resolved

The incident was caused by a spike in database CPU utilization, which resulted in intermittent service availability while the database recovered automatically.

Once the recovery process was completed, all services returned to normal operation, and no further issues have been observed.

We will continue working on systemic improvements to reduce the risk of similar incidents occurring in the future.
Posted Jul 28, 2026 - 13:09 UTC

Update

The database has remained stable, and we have not observed any further service disruptions since the incident.

Our team is continuing to investigate the root cause together with our infrastructure provider and is reviewing the database workload and connection behavior observed during the event.

We will keep monitoring the environment and provide another update once the investigation is complete.
Posted Jul 23, 2026 - 17:25 UTC

Monitoring

We identified a database outage at approximately 4:00 PM BRT, causing temporary access issues across some platform services.

Our team is monitoring the environment recovery together with our infrastructure provider. The database is currently undergoing a rebalancing process, and we are closely following the service restoration.

We will provide further updates as soon as more information becomes available.
Posted Jul 22, 2026 - 20:05 UTC