Scheduled Ticket Processing

Incident Report for NextQS

Postmortem

Incident Review — Scheduled Ticket Processing

We identified and resolved an incident that affected the inclusion of scheduled tickets in the NextQS processing queue.

What happened

Last Thursday, we performed an infrastructure update. After this update, one of the components involved in the scheduled ticket processing flow started running with a configuration that was not compatible with our environment.

Although the component appeared to be operating normally, the issue prevented some scheduled tickets from being sent to the processing queue as expected. Because there were no clear error messages or alerts, the issue was not identified immediately.

Impact

During the affected period, some scheduled tickets were not included in the NextQS processing queue.

After the issue was corrected, all pending scheduled tickets were processed and included in the system.

Correction applied

Once the cause was identified, we adjusted the affected configuration to use the correct setup for our environment.

After this change, the scheduled ticket processing flow returned to normal.

Preventive actions

To reduce the chance of a similar issue happening again, we will take the following actions:

  1. Improve monitoring for this processing flow, so interruptions or unexpected behavior can be identified more quickly.
  2. Strengthen our post-update validation process, including checks for the main system flows affected by infrastructure changes.
  3. Review critical configurations to avoid unintended changes during future updates.

We apologize for the inconvenience and remain committed to the stability and continuous improvement of the NextQS platform.

Posted Jun 03, 2026 - 15:15 UTC

Resolved

Incident Notice

We identified an incident related to the processing of scheduled tickets in NextQS.

Last Thursday, during an infrastructure update, one of the components responsible for sending scheduled tickets to the processing queue started running with an incompatible configuration.

As there were no clear error messages or alerts at the time, the issue was not immediately detected. It was later identified after reports that some scheduled tickets were not appearing as expected.

The issue has since been corrected, and the affected tickets that had remained pending were processed and included in the system.
Posted Jun 03, 2026 - 09:00 UTC